• Welcome to MX Bikes Official Forum. Please login or sign up.
 
January 27, 2021, 02:36:54 AM

News:

MX Bikes beta15d available! :)


impossible to join a server

Started by brems294, October 27, 2020, 06:23:48 PM

Previous topic - Next topic

iNsane

October 28, 2020, 02:04:17 PM #15 Last Edit: October 28, 2020, 02:07:53 PM by iNsane | WW
So to summarize my thoughts with all possibilities which lead into connection timeouts OR data mismatches

Connection time-outs:
- your connection to the host can't be established
= A workaround might be to use a VPN. Try Proton AND Windscribe because for me Proton worked first and suddenly it stopped working, then I switched to Windscribe and actually use it as my daily driver. This should work in most cases.

Data mismatches:
- old mods installed on your side
- old mods installed on the host side
- especially tyre mods cause errors
Explanation:
1: you have mod tyres & host has mod tyres = ok
2: you have mod tyres & host has stock tyres = mismatch
3: you have stock tyres & host has mod tyres = mismatch
4: you have stock tyres & host has stock tyres = ok
== Server AND Clients always need same tyre simulation files! The .EDF (3d model) can be different but not the simulation values.

Data mismatches ALWAYS happen due to different simulation files between host AND client!
Imagine you join a server on a 250 but with a modified engine so it's as fast as a 500. Would it make sense that you're able to join a lobby then? No!

Possible solutions
1: remove ALL tyre mods from your installation folder or mods folder
2: remove ALL mods, completely. Make sure a fresh installation with NO mods and everything stock works on stock servers such as MyMXB or SteamVR!

This is now especially weighted on tyre mods as NO tyre mod has been updated for B15 yet! Everything else should work, not work, or break your game but not cause mismatches.

That's what's on my mind.


   🌐 MX Bikes custom content
MXB-Mods.com

   📚 MX Bikes User Wiki
MXB-Wiki.com

   💸 Feel free to donate
PayPal

brems294


do you think it is correct?


really thanks for your help guys!

brems294


I use a VPN since yesterday: proton but it does not work ..
I will test with the other Windscribe vpn
and I keep you informed

For mods I don't think that's the problem. I can join the server steam. and vr.
I have more mods there.

brems294

with the windscribe vpn I have more connection timeout but it remains in syncing without access. there are better but still not that.

brems294


I use a vpn now, I have test with nordvpn and
I no longer have the connection timout problem, but I remain in syncing mode. If anyone has a solution? There is surely a manipulation to be done. but not being a computer expert I would not want to do anything.

Ruubs

Turning down my graphics usually fixes my infinite syncing problems.
On Erzberg I even have to set my resolution to the lowest it can go. Once I'm in the server I can increase it again.

DankVapours

Good day gents. I too suffered from these problems, but HAVE NOW FIXED IT.
1. I got connection time-out. After some testing, it became apparent that the mx-bikes.com domain was not registered with my ISP's DNS server. The domain was unknown. This was fixed by using Nord VPN.
2. This then led to infinite syncing. This stumped me for a bit, until I decided to utilise the Nord service DNS, but WITHOUT their VPN. Please follow this guide: https://support.nordvpn.com/Connectivity/Windows/1088041672/Change-your-DNS-servers-on-Windows.htm

I can now connect to servers.

teeds

It sounds like you could just change your DNS settings to achieve the same thing but without VPN software? Google DNS is 8.8.8.8 and 8.8.4.4, be interesting to know if that change alone works for you too.
"Damn dirt bikers!" - Bubba

DankVapours

You're quite correct teeds, I didn't make that clear. I used the Nord VPN DNS server (which is freely available and doesn't require the Nord VPN software or account) because I knew it worked.

Alternatives such as Google DNS or OpenDNS may also work, but I have not tested them. Christmas day and all means my time at the PC is quite limited!

teeds

"Damn dirt bikers!" - Bubba

bastey

Hi guys,

for a non-computer-dude: Could you just elaborate on what you exactly did?

I tried changing my IPv4 to the Server you mentioned, like this:
https://support.nordvpn.com/Connectivity/Windows/1088041672/Change-your-DNS-servers-on-Windows.htm

Meanwhile i tried the method with windscribe. After a short time waiting there is no "connection timeout" issue but i can move the mouse after a short time of "syncing" and my friends who already ride at the server tell me, i disconnected already.

Is there anything else i can do?

teeds

Did you establish what you and the host are running IPv6/4 wise? If both are on IPv6 then it's this protocols DNS that might need altering rather the than IPv4 ones.

Also if you are both only on different protocols (i.e. one of you is on IPv4 with no IPv6 and one has IPv6 but cannot run IPv4) this could be another reason for the problem you're getting. But if at least one of you can run both you can disable a protocol to test and prove it's the problem or not.

I take it your game does run perfectly in single player mode?
"Damn dirt bikers!" - Bubba