• Welcome to MX Bikes Official Forum. Please login or sign up.
 
June 17, 2019, 08:44:17 am

News:

MX Bikes beta10c available! :)


Controls not responding

Started by тғc, March 03, 2016, 12:09:05 pm

Previous topic - Next topic

тғc

Not sure it's something I could replicate or explain, but I've loaded MXB up this morning and none of my controls work.

Not just controller but keyboard, can't even press ESC in game to bring the menu up. Have to open task manager to close MXB.

Strangely, if I reload game and go to input settings my controller doesn't show the movements even though its calibrated. When I calibrate it, it works. But the keyboard still doesn't..

Any ideas?   ??? :-\
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

teeds

Hmm sounds very odd Fats, tried renaming your piboso folder and testing again? Guessing your configs might be corrupt.
"Damn dirt bikers!" - Bubba

тғc

Just done a partial reinstall and then a full clean wipe reinstall with no luck :(
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

тғc

Quick update. I can map my Xbox One controller fine in the settings but I CAN'T map keys. Key presses don't respond.

But, I CAN type my nickname on the profiles screen..

Please help PiB!! :(
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

тғc

Another update.. If I unplug my controller key bindings work fine.

Have tried reinstalling the controller driver, rolling back, and trying xbox gaming device instead of xbox one driver. No joy..
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

тғc

OK after much messing about I think it's working using the xinput plugin. But it's still broken.

Before, I used to have to start MXB with my controller connected or it wouldn't even calibrate. Now if I do that I can't use the keyboard.

What I have to do now is start MXB without my controller connected, connect it once things are loaded and it works using xinput alongside the keyboard.

Weird.. Anyone else? Piboso? any ideas or maybe just something to look into for the next beta maybe to do with input profile / calibration? Maybe there are some temporary files I should remove somewhere?
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

teeds

"Damn dirt bikers!" - Bubba

тғc

Weird... And today too..

I think I did have a Windows Update this morning. Think**.. Can't remember I restarted a few times.
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

BanoPini

March 03, 2016, 07:13:36 pm #8 Last Edit: March 03, 2016, 07:20:53 pm by BanoPini
Hi TheFatController,
Your same problem........ :-[
same problem with gpbike,

windows 10 pro 64 (update today  ??? :o)
Xbox One controller

тғc

BanoPini, have you tried the xinput fix I posted above mate?

Reply #5
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

BanoPini


Snappe

So you're both having problems with the Xbox One controller... Did it work in previous betas?

JiBuS

My friend had the same problem, keyboard doesn't work in game, W10 x64 XB1 controller. And it worked fine before the B4.

тғc

It's not beta 4 it's Windows.. Yes, worked just fine since beta 1. In fact I was using it at the time yesterday, restarted and there was a Windows update, reloaded to find the problem.

It also extends to tracked, where if I have the controller plugged in I am unable to navigate in marshal / cam placement using the arrow keys and ctrl.
Last Project Alta Redshift MXR


Current Project Hawkstone Replica


Next Project Unknown


Buy Me a Beer

HeWhoHordesManyPillows

March 06, 2016, 04:20:38 am #14 Last Edit: March 06, 2016, 04:23:43 am by HeWhoHordesManyPillows
cpu: Intel Core i7 6700k @ 4.4ghz
gpu: Nvidia GTX 780
OS: Win 10 x64 Pro
Controller: Xbox One Wireless

Can map the controls just fine but the keyboard other than Profile Naming, is unresponsive. Can't even Esc to Menu once ingame.
Just as Fats showed.

EDIT: xinput has fixed it for me if I follow directions. Seems lame of the change. (micro$oft.)
- Life could be simple