• Welcome to MX Bikes Official Forum. Please login or sign up.
 
April 06, 2020, 12:51:54 am

News:

MX Bikes beta14 available! :)


Need help with Reflection Map problem [SOLVED]

Started by Resolute Kraken, April 03, 2020, 08:30:17 pm

Previous topic - Next topic

Resolute Kraken

April 03, 2020, 08:30:17 pm Last Edit: April 04, 2020, 12:02:34 am by Resolute Kraken
Solved Problem was that I did not have a normal map defined in addition to the reflection map.  Simply made a flat normal map.

I hope that someone can help me out with a problem I'm having with a reflection map I'm trying to use for a texture on a simple plane (mud puddle).  When I add the reflection map shader, the model will not show in game - remove the shader and it shows fine.  Here is what I've done:

1. In my maps folder where the texture is for my model, I've copied the "env" folder from the example track


2. I have my shader file, texture file, and reflection map - texture works fine on model, when shader is not used.


3. In the shader file I have the following copied from the example track files. I've tried playing with some of the settings in there but nothing seemed to matter (default factormin = 0.1 - doesn't work also).


4. The reflection map is simply all white with the alpha channel correctly set


5. Run fbx2edf_x64 to convert the models and map.bat to build.  No errors are shown.

Again, the problem is that when the shader is used the object does not show up in game, removing the shader it then shows up fine with the texture correctly.  This is probably something simple that I'm overlooking. Thanks to anyone that can assist.